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Simulering av elektriska kretsar med LTSpice

1 Introduktion

Det finns hundratals program for simulering av elektriska kretsar. Huvuddelen av dessa bygger pa
programmet SPICE (Simulation Program with Integrated Circuit Emphasis). SPICE é&r ett gratis
textbaserat program som utvecklades pa Berkeleyuniversitetet pa 1970-talet. Det &r ganska knéligt att
anvanda da man maste mata in sin krets i form av s k nétlistor i en texteditor.

For att underlatta anvandandet har det utvecklats grafiska skal som gor att man kan mata in sin krets genom
att rita sitt kretsschema i en schemaeditor samt vélja simuleringskommandon i dialogrutor.

Det som framst skiljer de olika SPICE-programmen at dr hur schemaediteringen, ”Schematic Capture”,
fungerar samt hur simuleringsresultaten presenteras i en s k "Waveform Viewer”.

Aven hur man véljer olika simuleringskommandon skiljer sig t mellan de olika programmen.

Ett vanligt SPICE program ar PSPICE fran Cadence som ingar i ett komplett CAD-paket for
elektronikkonstruktion. En begransad demo finns att ladda ner fran tillverkaren. Nackdelen med PSPICE
ar att troskeln for att komma igdng med programmet ar hog och att det ar dyrt att skaffa en fullversion.

Multisim fran National Instruments &r ett annat mycket bra simuleringsprogram. Programmet anvander
?virtuella instrument” for att presentera simuleringsresultatet. Man ser med andra ord
simuleringsresultatet m h a oscilloskop, multimetrar mm som placeras ut i schemat.

Det ser snyggt ut och &r enkelt att anvanda men nackdelen &r att det kan vara svart att ga 6ver till andra
Spiceprogram eftersom man kanske inte inser vilket simuleringsalternativ som anvands av de olika
”virtuella instrumenten”.

LTSpice fran Linear Technology ar ett annat program som ar mycket bra.
En gratis fullversion finns att ladda ner fran tillverkaren pa adressen:

http://www.linear.com/designtools/softwareReqistration.jsp

Fordelarna med detta program é&r att det ar en gratis och har inga begréansningar da det galler kretsstorlek.

Andra fordelar ar: Snabb simulering, relativt enkelt att anvanda och att det ar relativt enkelt att ga over till
andra SPICE program da man lart sig LTSpice. Nackdelen med LTSpice &r att grafiken inte ar lika snygg

som i manga andra program.

Adress till en bra diskussionsgrupp som behandlar LTSpice &r:

http://tech.groups.yahoo.com/group/LTspice/

I denna diskussionsgrupp finns tusentals SPICE-modeller att ladda ner samt hur mycket material som
helst att ta del av.

Ett alternativt bra gratis SPICE-program &r TINA-TI som har snyggare grafik &n LTSpice men &r lite
svarare att anvanda. TINA-TI har inga begransningar pa kretsstorlek men licensen tillater inte att
programmet anvénds i utbildningssammanhang.


http://www.linear.com/designtools/softwareRegistration.jsp
http://tech.groups.yahoo.com/group/LTspice/
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Standard simuleringsalternativ i SPICE

DC-operating point

Potentialer i alla noder beréknas likspanningsmaéssigt med ideala spolar behandlade som kortslutningar,
ideala kondensatorer behandlade som avbrott samt med alla véxelspanningskallor nollstéllda.

Transient analysis

Analys i tidplanet som anvander sig av komponenternas kompletta olinjara modeller.

Detta ar den vanligaste analysen och kan anvandas for att studera saval insvangningsforlopp som
stationarforlopp. Eventuella insignaler kan ha godtyckligt utseende. Frekvensinnehallet i kretsens alla
signaler kan studeras med FFT. Vid transientanalys ingar vanligen att programvaran gor en inledande
DC-operating point analys vilket medfor att man inte behéver géra nagon sadan separat.

AC analysis

Denna analys ar en smasignalanalys som forst gor en bestamning av likstromsarbetspunkten for kretsen,
DC-operating point. Sedan beraknas en linjar sméasignalmodell av kretsen runt arbetspunkten for
véxelspanningar. Anvands for att plotta frekvensfunktioner (Bodediagram) for kretsar samt berékna t ex
in- och utimpedans.

DC sweep

Stegar en eller flera DC-kallor i ett intervall och beréknar likstromsarbetspunkten for kretsen med ideala
spolar behandlade som kortslutningar, ideala kondensatorer behandlade som avbrott samt med alla
véxelspanningskallor nollstallda. Anvénds t ex for att plotta statisk overforingskarakteristik for
komponent eller krets.

Noise

Denna analys ar en smasignalanalys som forst gor en bestamning av likstrémsarbetspunkten for kretsen.
Sedan beraknas en linjar smasignalmodell av kretsen runt arbetspunkten for vaxelspanningar. Slutligen
skapas en brusmodell for kretsen.

DC transfer
Denna analys ar en smasignalanalys som forst gér en bestamning av likstromsarbetspunkten for kretsen.
Sedan beraknas en linjar smasignalmodell av kretsen runt arbetspunkten for likspanningar. Slutligen

berdknas forstarkning samt in- och utresistans for kretsen vid frekvensen 0 Hz.
Denna analys ar inte sa mycket anvand eftersom man enbart erhaller resultatet for frekvensen 0 Hz.

2 LTSpice

De féljande avsnitten ar en lathund for att snabbt komma igang med schemaritning och de vanligaste
simuleringstyperna i LTSpice. Som vanligt kan det mesta annat hittas i programmets hjélpfiler.
Idéer kan aven fas i exemplen i katalogen: C:\ ........ \LTC\LTspice\examples\Educational.

Rita kretsschema i LTSpice

Starta LTSpice.

Valj File > New Schematic

Fonstret kommer att se ut som pa nasta sida forutom det uppritade schemat.

For att rita upp schemat gor pa foljande satt:
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FejLTspice I¥ - [Draft1] =10l x|

-l: File Edit Hierarchy ‘Wiew Simulate Tools Window Help /\ ==l
|Be WP F0|Q0aR| B SaE i &L+l TDVOD o @ |

Q1 BC337-25 uT

vl R2
1avh RL -, 1000hm

N
1.5kohm D1
BZX84C6V2L

.op

4
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For att placera ut ett motstand klicka
Flytta musmarkor till dnskad position.
Om du vill rotera komponenten medurs tryck: Ctrl+R

Om du vill spegelvanda komponenten tryck: Ctrl+E

Vansterklicka for att placera komponenten.

Fortsatt att placera ut de andra motstanden pa samma satt. Hogerklicka for att avsluta.

Kondensatorer, spolar, dioder och jordsymboler placeras pa samma satt.

OBS! Kondensatorer, spolar och spanningskallor i schemat kan tilldelas serie- och parallellresistans mm.
De &r alltsd inte n6dvéandigtvis ideala utan motsvaras i ett berdkningsschema av den ideala komponenten
serie- och parallellkopplade med andra ideala komponenter.

<

OBS! Varje krets maste innehalla minst en jordsymbol eftersom programmet arbetar med

nodanalys.
Ovriga komponenter finns under symbolen

Placera ut spanningskalla, transistor och zenerdiod: voltage, npn och zener under symbolen

g

Koppla samman komponenterna genom att vilja wire-verktyget”

Vansterklicka pa en punkt forst, klicka sen pa en mellanliggande punkt dar du 6nskar en 90 graders krok,
klicka slutligen pa dndpunkten.

Da4 alla “tradar” dragits avsluta med hdgerklick.

Andra verktyg som kan vara anvéndbara vid schemaritning:

&

”Cut” Raderar komponenter, forbindelsetradar, text m m.

g ”Move”  Flyttar komponent (eller text) utan att férbindelsetradar féljer med.
Anvands aven da man vill rotera eller spegelvanda en redan placerad symbol

v “Drag”  Flyttar komponent. Forbindelsetradar foljer med.

“Text”  Placerar ut kommentartext i schemat.
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”Label Net” Tilldela de noder som &r av intresse lampliga unika namn. | exemplet: UT.
De noder som inte tilldelats namn far ett nodnummer tilldelat av programmet som ej
syns i schemat. Noder som har samma namn &r elektrisk hopkopplade vilket kan
anvandas for att ge ett snyggare schema.

Tilldela komponenterna varden genom att hogerklicka pa dem.

Anvand decimalpunkt. (Decimalkomma kan ge svarfunna fel utan varningsmeddelande)

Man behover inte skriva ut enheterna V, A, ohm, F, H, Hz e t ¢ men det &r ibland bra att gora det.
L Tspice ar "case insensitive" d v s skiljer inte pa gemener och versaler.

Anvandbara prefix: (OBS prefix maste skrivas direkt efter komponentvardet utan mellanslag)

f = femto oBS!! F=f=femto
p = piko

n = nano

u = mikro

m = milli

k = kilo

Meg=mega OBS!! M=m=milli
G =giga

T =tera

For zenerdioden: Hogerklicka, Valj: Pick New Diode, Vilj: BZX84C6V2L
Valj transistor pa samma sétt.

Om man vill &ndra texten vid komponenten t ex R2 och V1.
Hogerklicka pa texten och skriv in 6nskad text samt valj eventuell textjustering.

3 Simulera krets. DC-analys av arbetspunkt

Vaélj Simulate > Edit Simulation Command
Hé&r kan man valja typ av simulering.

Edit Simulation Command |

Transientl AL .fi‘n.nalysisl OC sweepl Muoize I DC Transfter  DC op prt |

Compute the DC operating point reating capacitances as open circuits and
inductances as shart circuits.

Syntaw: op

.op

Cancel |

For DC analys vélj fliken DC op pnt. Bekréfta med OK
SPICE-direktivet .op som talar om typen av simulering kan nu placeras i schemat.
2

Kor en simulering Simulate>Run
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LTSpice berdknar nu alla nodpotentialer och strommar genom komponenterna med ideala spolar
behandlade som kortslutningar, ideala kondensatorer behandlade som avbrott samt med alla
vaxelspénningskéllor nollstéllda. En lista med nodpotentialer och strommar genereras. Se nedan:

I * C:\Program’LTC'LTspiceI¥"Draftl.asc ll
——= Operating Point —--—- 1=

W nOo02) - 6.3011 woltage

WV (nO01) : 1z voltage

Wluk) o 5.57693 voltage

I (2l = 0.0555659 device_current

Ik (ol : 0.000203472 device current

Ie(2l) = -0.0557694 dewvice_ current

I(D1): -0.00359579 device current

I(Rl): 0.0557e94 dewvice_ current

I(RZ) : 0.003799z7 device current =

T(WV1l): -0.0593651 dewvice current LI

Strommar genom spanningskallor har referensriktning in pa +, darav minustecknet for 1(V1) ovan.
Strommar genom motstand, kondensatorer och spolar har referensriktning beroende pa hur de placerats i
schemat sa ignorera eventuellt minustecken framfor strommarna och avgor strommens riktning m h a
nodpotentialerna. Tycker du att eventuella minustecknen for strmmar genom motstand, kondensatorer
och spolar ar storande kan man géra pa nagot av féljande tva satt:

1. Vilj = ”Move” verktyget och rotera komponenten ett halvt varv m h a Ctrl+R.

2. Tahéansyn till komponentens riktning redan da du ritar schemat.
Strommens referensriktning ar in i komponenten uppifran da du valt komponent.
Roterar du komponenten ar strommens referensriktning in fran hoger.
Roterar du komponenten och spegelvéander den ar strommens referensriktning in fran vénster.

Om man stanger fonstret ovan kan man anda studera nodpotentialer och strommar genom komponenter
samt dven forlusteffekt i komponenter genom att placera musmarkdoren i noder respektive pa
komponenter. Aktuell storhet kan avl&sas i statusraden l&ngst ner till vanster i fonstret.

P& samma satt kan man erhalla information om arbetspunkten da man har valt simuleringstyperna
Transient, DC Transfer eller AC Analysis vilket gor att val av DC op pnt oftast ar onodig.

I bilden nedan har musmarkoéren (hand) pekat pa R2.

Om man vill se nodpotentialerna inne i schemat gor pa ett av féljande tva satt:

1. Klicka pa 6nskad nod. Detta fungerar bara da endast DC-analys gors.

2. Hogerklicka pa tom yta i schemat. Vlj: View>Place .op Data Label. Klicka pa énskad nod.
Detta alternativ fungerar dven vid Transientanalys och AC-analys

FéjLTspice 1¥ - [Draft1] =1ol x|

'l: File Edit Hierarchy Wiew Simulate Tools Window Help ;Iilﬂ

| P [P *0Q0AR| BRI ARE| s REMAS L SDE3 YDDDD O
Q1 BC337-25 uT

V1 7+ R2
12V RL 1000hm

N
1.5kohm D1
BZX84C6V2L
op

Right click to edit RZ@ point: IRZ) = 3,79927mA  Dissipation=21,6516mW A

Strom och forlusteffekt




4 Simulera krets. Transientanalys

Detta ar den vanligaste simuleringstypen dar man erhaller information om bade arbetspunkt och

insvangningsforlopp samt stationartillstand om simuleringstiden &r tillrackligt lang.

Man kan aven erhalla frekvensspektrum m h a FFT.

Rita upp nedanstaende schema:

mLinear Technology LTspice/SwitcherCAD III - Draft2.asc
File Edit Hierarchy WYiew Simulate Tools window Help
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~=1olx]

B A% #0 Q0% BN ERE s DEN OB LoD +3 IDDODC 4
=10 x]
- uT
D1 D2
V1 AN
T 1N4148] 1N4148 1
o R1
SINE(0 10V 50Hz) 2K D4 220pF < 1000hm
AN
1N4148 1N4148
~7
Aran 0.1s
VA

For att erhalla sinusformad vaxelspanning fran spanningskallan hogerklicka pa kéllan och valj Advanced.
Fyll i dialogrutan som dyker upp enligt figur nedan:

Independent ¥oltage Source - ¥1 |

r~ Functions
" [none]

" PULSEPM %2 Tdelay Trige Tfall Ton Period Meycles)
' SIME[Waffzet Yamp Freq Td Theta Phi Hoycles)
 EXPM1 V2 Td1 Taul Td2 Tauz)

™ SFFM[Voff Wamp Fcar MDI Fig)

Pyl w1 1242,

DC offzetlv]: ID

Amnplitude]: |10
Freq[Hz]: IW
Tdelay[z]: |

Theta[1 /]
Phidea [
Meopcles: I—

I—

fdditional PwlL Paints |

M ake this infarmation vizsible an schematic: W

= e Yalue

[E walue: I

take this information visible anschematic: [#

 Small gsignal AC analyzis[ALC)

AL Amplitude: I
I—

AC Phasze:

M ake this information visible on schematic: v

i~ Parasitic Properties

Series Resistance[Q]: I
Parallel Capacitanice(F]: I

M ake this information visible on schematic: v

Catizel |

Bekrafta med OK.
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Vaélj Simulate > Edit Simulation Command
Hé&r kan man valja typ av simulering.

For Transientanalys valj fliken Transient.
Fyll i 6nskad simuleringstid enligt figur nedan Bekrafta med OK

Edit Simulation Command x|

Tranzient |f—'«|: Analy&isl DC meepl Moize I oc Tramferl DC op |:unt|

Ferform a not-linear, time-dormain zimulation.

Stop Time: ID.‘IS

Time to Start Saving Data: I—

b azimum Timestep: I—
Start external DC supply voltages at 0 [
Stap simulating if steady state is detected: [
Dt reset T=0when steady state iz detected: [T
Step the load curent source; [

Skip Initial operating point solution: [

Suntax: _tran <Tstop: [<optioh: [<optionz] ..]

tran 01

Cancel |

SPICE-direktivet .tran som talar om typen av simulering kan nu placeras i schemat

Kor en simulering * Simulate>Run.
Antag att vi vill plotta potentialen i noden UT:
Stall musmarkoren i noden UT och en réd matprob dyker upp.

Klicka och potentialen i noden UT ritas i plotfonstret.

mLinear Technology LTspice/SwitcherCAD III - Draft2.asc - |EI|1|

File Edit Hierarchy WYiew Simulate Tools window Help

| BSEF 40 QAR L AR I REMR OB LD L3 IDDTD

=101 x]
. uT P
D1 D2
Vi AN
T 1N4148| 1N4148 -
L R1
SINE(0 10V 50Hz) = D4 220pF 1000hm
N
1N4148 | 1N4148

ran 0.1s

4
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For att plotta strommen genom exempelvis dioden D1:

Stéall musmarkoren 6ver komponenten och en “’stromtédng” dyker upp. '£
Pilen anger strommens referensriktning. Klicka och strommen ritas i plotfonstret.

Man kan plotta momentaneffekten i en komponent genom att halla nere Alt + Klicka pa komponent.

(Musmarkdren andrar utseende till en termometer nar den befinner sig pa en komponent) I\E:

Matningar i plotfonstret kan géras pa tva satt:

1. Hall musmarkdren 6ver en punkt pa kurvan, koordinaterna visas i statusraden nere till vanster i
fonstret.

2. Infor matmarkaérer genom att klicka pa variabelnamn i plotfonstret. Om man klickar ytterligare en
gang fas 2 markdrer. Dra markérer med musen.

Man kan andra skala i plotfonstret genom att klicka pa skalorna i plotfonstret.

Man kan ocksa zooma in en del av plotfonstret genom att halla ner véanster musknapp och dra upp en
rektangular ruta for det intressanta omradet.

Man kan fa tva 2 diagram i plotfonstret genom att hogerklicka och vélja Add Plot Pane.

Man kan mata spanningen mellan 2 noder genom att klicka pa ena noden och hélla vanster musknapp
nere medan man flyttar musmarkdren till den andra noden.

Man kan mata strommen i en ledare genom att halla nere Alt + Klicka pa ledaren.

Man kan ta reda pa medelvardet och effektivvardet for en plottad storhet genom att halla nere Ctrl +
Klicka pa intressant storhet i plotfonstret.

Man kan erhalla tjockare kurvor i plotfonstret:

Tools>Control Panel> eller |i
Under fliken Waveforms: Vélj: Plot data with thick lines.

Vid utskrift av plotfonstret kan det ibland vara fordelaktigt med vit bakgrund:

Tools>Color Preferences>

Under fliken Waveform , Selected Item>Background, Vilj vit bakgrundsfarg genom att stélla
skjutreglagen for rott, gront och blatt pd maximum.

Om man onskar ett FFT-spektrum:

Placera SPICE-direktivet: ”.options plotwinsize=0" pa ritningen med knappen °F

Vilj: Simulate > Edit Simulation Command, under fliken Transient valj Maximum Timestep sa att
antalet berédkningspunkter under simuleringstiden &r mycket stérre an antal datapunkter i FFT:n.
Dessa 2 val gor att dynamiska omradet for FFT-spektrat blir mycket storre en defaultinstallningen i
LTSpice.

Kor en simulering * Simulate>Run.

Klicka pa plotfonstret och valj: View>FFT.



5 Simulera krets. Transientanalys med pulstag.

Nedan syns ett schema som beskriver hur man driver reldspolar med en transistor, en mycket viktig

tillampning. Rita upp schemat.

mLinear Technology LTspice/SwitcherCAD III - Draft4.asc
File Edit Hierarchy “iew Simulate Tools Window

Help

=lolx]
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PSR 40 QR0QR(IR ERE $BENOS LB TDNOD Ok

0/
L1 D1
c)MH /N
1N4148
V2
; O
R1 Q2 12v
Vi
10k 2N2222
PULSE(0 5V 0 10n 10n 0.8s 1s)
Aran 5s
4

Spole L1 ska representera en reldspole. Vélj dess induktans till 1H och dess serieresistans till 1 kohm.
Kallan V1 skall representera utgangen pa en mikroprocessor. Vi 6nskar ett periodiskt pulstdg med
perioden 1s och pulser som ar 5V under 0.8s. For att efterlikna mikroprocessorutgangen valjer vi stig- och

falltid till 10 ns.

Fyll i egenskaperna for kéllan V1 enligt figur nedan:

Independent Yoltage Source - ¥1

i~ Functions

" [none)

© EXPRA W2 Td1 Taul Td2 Taul)
™ SFFM[Woff Wamp Fear MO Fsig)
Pl w1 k2 w2 )

Trise[s]:
Trall(z]:

{* PLILSEM %2 Tdelay Trise Tiall Ton Period Neycles)
™ SINE[Voffset Wamp Freq Td Theta Phi Neycles)

Yinitial[v]: ID
o[Vl IE\-"
Tdelay(s]: IIJ

10n
10n

Ton[s]: IU.ES
Tpenod[z]: |1$
Meoycles: I

Sdditional FwL Foints

Malke this information visible on schematic: v

- DE Walue

DT value: I

tdake this infarmation visible on schematiz: [

 Small zignal AC analyziz] AC]
AC Annplitude: I
AL Phaze: I

Make this information visible on schematic: v

i~ Parasitic Properties

Seriez Resigtance[n]: I
Parallel CapacitancelF]: I

b ake thiz information vizsible on schematic: [v

Cancel |

X

Vilj transientanalys med en simuleringstid pa 5 sekunder. Kor en simulering
Nu kan man t ex méta upp max kollektorpotential for transistorn samt transistorns bottningsspanning.



10(23)

6 Simulera trefassystem

Antag att man vill simulera ett trefassystem med 400V huvudspénning och frekvensen 50Hz.
Rita upp schemat nedan.

mLinear Technology LTspice/SwitcherCAD III - Draft4.asc - |EI|1|

File Edit Hierarchy Wiew Simulate Tools ‘Window Help

BE R P FN QR L ERE| L BN OE| LLB LI YOO i op

Draftd.asc O] x|
V1
U1 R1
SINE{0 326V 50Hz 0 0 0) 4@7—\/\/\—
100
s 17 s
SINE{0 326V 50Hz 0 0 -120) ._@7_\/\/\_
50
= U3 S
SINE{0 326V 50Hz 0 0 240) »—@7—\/\/\—
30
w7
tran 0.1
4

Fasforskjutningen pa -120° resp. -240° erhalls genom att fylla i Phi[deg] enligt dialogrutan nedan.

x
r~ Funictions D Yalue
 [hone) I walue: I—
e PULSE[¥1 %2 Tdelay Trige Tfall Ton Period Neoycles) Wake this information visible om schematic; IE
% SINE[Woffset Wamp Freq Td Theta Phi N cycles)
" EXPM1 V2 Tdl Taul Td2 Tau2) — Small zignal AC analysis].ALC)
" SFFM(Voff Yamp Fear MDI Fsig) ACAmpitude: [
PWLIN vl 122 AT Phase: I—
e ID— Make this infarmation visible on schematic: V.
Amplitudel} I& [resste P[DSD::iiiSH esistance[Q]: .
FrealHz]. |S0Hz Parallel CapacitanceFl:
T;::;yjj g Make this information visible on schematic;
Phildeg]: [-120
Meypcles:
I—

AddiionalPwl Paints |

Make this information visible on schematic: [V Cancel |

Vilj transientanalys med en simuleringstid pa 0.1 sekunder. Kor en simulering.

Plotta samtliga linjestrommar.

Man kan mata strommen i en ledare genom att halla nere Alt + vansterklicka pa ledaren.

Man kan ta reda pa medelvardet och effektivvardet for en plottad storhet genom att halla nere Ctrl +
vansterklicka pa intressant storhet i plotfonstret. Bestam pa detta satt samtliga linjestrommars
effektivvarden.




7 Simulera transmissionsledningar
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Antag att man vill simulera hur ett 5 V spanningssteg uppfor sig pa en forlustfri transmissionsledning
med karakteristiska impedansen Z,= 50 Q och 16ptiden T4 = 50 ns.

Rita upp schemat nedan. Forlustfri transmissionsledning: tline under symbolen

FéjLTspice I¥ - [Draft1]

-l: File Edit Hierarchy Miew Simulate Tools Window Help

=101 x|
=& x|

| BEETF0 QR IBI ERE &M A8 L0

R2

10
V1

PULSE{05V 0 1n)

T1 R1

Aran 1000ns

Td=50n Z0=50

500

i

Steget pa 5 V med stigtid 1 ns erhalls genom att valja parametrar for spanningskallan enligt nedan:

x
r~ Functions - DE e
" [none] [ walue: I

* PULSE[1 W2 Tdelay Trize Tfall Ton Period Meycles)
= SIME[offset Yamp Freq Td Theta Phi Meycles)

° EXPI V2 Tl Taul Td2 Tau2)

= SFFM [off Wamp Foar MDI Fsig)

 Pwilit vl 242

Addiional Pl Poiris |

bake this information visible on schematic: v

fd e this information visile on schematic: [

 Small signal AC analpsis[.AC)

AL Amplitude: I
AC Phase: I

Make this information visible on schematic: v

" Pwl FILE: | Browse |
— Parazitic Properties
Viritialv]: [0 Senez Resistance[0]:
Vorv]: [57 Parallel Capacitance(F]:
Tdelayls]: ID— Make this information visible on schematic: IV
Tnzez]: [1n
Tall[z]:
Ton[z]:
Tpeniod[z]:
MHeycles:

Cancel |

Valj transientanalys med en simuleringstid pa 1000 ns. Kor en simulering.
Genom att klicka pa nér- respektive fjarrande pa transmissionsledningen kan man studera spanningarna i

ledningens bada andar.
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8 Simulera krets. DC sweep

Om man &r intresserad av Overforingskarakteristik for en komponent eller en krets kan man anvénda
simuleringstypen DC sweep. DC sweep stegar en eller flera oberoende spénnings- eller stromkallor i ett
intervall. Ideala spolar behandlas som kortslutningar, ideala kondensatorer behandlas som avbrott och alla
véxelspanningskallor &r nollstéllda.

Man kan sedan vélja att visa valfri strém eller spdnning som funktion av den variabla stegade
spanningen/strommen.

Vi ska hér anvanda funktionen for att rita upp strém-spanningskarakteristiken for en diod.

Rita upp nedanstaende schema. Hogerklicka pa spanningskallan valj OK

FijLTspice I¥ - [test3] =10l |

-[: File Edit Hierarchy View Simulate Tools Window Help _|5’|i|

| BS M *0QceR(Ed B i2RH a8l Lo+

Vi D1
Vi

1N4148

Vaélj Simulate > Edit Simulation Command
Hé&r kan man valja typ av simulering.

For DC sweep vilj fliken DC sweep.

Fyll i enligt fig nedan. Bekrafta med OK

Edit Simulation Command x|

Transientl 4L Analysis DC sweep | Moise I DC Transferl DC op pht

Compute the DC operating point of a circuit while stepping independent sources and
treating capacitances as open circuits and inductances as short circuits.

12t Saurce | 2nd Source | 3id Source |

Mame of 1st Source to Sweep: IW—
Type of Sweep: m

Start Value: ID—

Stop W alue: IDE"J—

Increment: IW

Spmtax: .do <Sourcels [<oct.dec lin:] <Starty <Stops [<Iners] [<sources ...]

.de W1 008y 0.01Y

Cancel |

SPICE-direktivet .dc som talar om typen av simulering kan nu placeras i schemat.

Kallan V1 kommer nu att stegas mellan 0V och 0.8V i steg om 0.01V
F

Vilj 6nskad storhet att plotta. Valj strommen genom dioden genom att klicka pa dioden.

Kor en simulering Simulate>Run

Nu ska du kunna studera strommen genom dioden [(D1) som funktion av spanningen V1 gver dioden.
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9 Simulera krets. DC Transfer
Om man har en DC-kopplad forstérkare, d v s en forstarkare som kan forstarka likspanningar kan man

enkelt fa reda pa likspanningsforstarkning samt in- och utresistans for forstarkaren.
Rita upp schemat nedan.

F8jLTspice I¥ - test4 o [=] B2

File Edit Hierarchy ‘iew Simulate Tools  window  Help

| E P 0 Qear B HEaE sB2ENA8| L@
test4 =101 x|

~7
2 e
>

HWUT) V3

Valj Simulate > Edit Simulation Command
Har kan man valja typ av simulering.

Valj fliken DC Transfer.

Fyll i enligt fig nedan. Bekréfta med OK

Edit simulation Command x|

Transient | AC &nalysis | DC sweep | Moize D Transfer | DL op prt

Find the DC small-signal transfer function.

COutput: I\-"[UT]
Source: I\-"3

Sentaw: Y [<out:[<ref:]] <sc:

|.th[UT]V3

Cancel |

SPICE-direktivet .tf som talar om typen av simulering kan nu placeras i schemat.

Denna analys ar en smasignalanalys som forst gor en bestamning av likstromsarbetspunkten for kretsen.
Sedan beréaknas en linjar smasignalmodell av kretsen runt arbetspunkten. Slutligen beraknas forstarkning
samt in- och utresistans for kretsen vid frekvensen 0 Hz.

2

Kor en simulering Simulate>Run.



10 Simulera krets. AC-analys (Smasignalanalys)

Antag att vi vill ta reda pa évre och undre gransfrekvensen for en inverterande
operationsforstarkarkoppling. Rita upp nedanstaende schema:

F&jLTspice I¥ - Draft2

File Edit Hierarchy Wiew Simulate Tools Window Help
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=lolx|

B3 BT 40 QCoR BRI CRE $REH OB L@ 3 YDUOD O

AC1

.ac oct 10 1Hz 10MegHz

1o x|
v+
Vi R3
-+ 220K
Ut 1 2‘<_> V42
c3 R4
RS 10p 220K
10k _I_
~
&

For att erhalla en signalkalla som &r anpassad for smasignalanalysen: Hogerklicka pa kallan, valj
Advanced. Fyll i dialogrutan som dyker upp enligt figur nedan:

Independent ¥oltage Source - ¥2

 Funchions

% [nane]
" PULSE[] W2 Tdelay Trise Tfall Ton Period Mopcles)
" SIME[offset Vamp Freq Td Theta Phi Moycles)
 EXPIVI W2 Td1 Taul Td2 Tauz)

" SFFM[Voff Yamp Foar MDI Fsig)

© PwLN w12 w2, )

" PwL FILE: |

Addiional PWL Poirs |

M ake this information vizible on schematic: [V

~ DCYalue

DL value: I

take thiz information visible an schematic: v

Brawse |

— Small zsignal AC analyziz[ AC)
AL Amplitude: I'I
AL Phaze: I

take this infarmation visible on schematic: W

 Parasitic Froperties

Seres Resigtance[0]: I
Farallel Capacitance[F]: I

Fake this infarmation visible on schematic: W

Cancel |

Bekrafta med OK.
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Vaélj Simulate > Edit Simulation Command
Hé&r kan man valja typ av simulering.

For AC-analys vilj fliken AC Analysis.

Fyll i enligt figur nedan. Bekréfta med OK

Edit Simulation Command x|

Trarsient  AC Analysis | DC sweepl M oize I oC Transferl DL op pht

Compute the zmall zignal AC behavior af the circuit lineanzed about its DC operating
poirit.

Tupe of Sween: Im
Mumber of pointz per octave: I'H]—
Start Frequency: I'IHZ—
Stop Frequency: W

Suntax: .ac <oct, dec, liny <Mpoints> <StartFregs <EndFreg:

Jacoct 10 1Hz 10kegHz

Cancel |

SPICE-direktivet .ac som talar om typen av simulering kan nu placeras i schemat.

Denna analys ar en smasignalanalys som forst gor en bestamning av likstromsarbetspunkten for kretsen.
Sedan beréaknas en linjar smasignalmodell av kretsen runt arbetspunkten. Slutligen skapas ett
Bodediagram som beskriver kretsens frekvensfunktion fran spanningskallan (AC 1) till den valda
utsignalen. Bodediagrammet plottas mellan en undre startfrekvens och en évre stoppfrekvens.

Kor en simulering * Simulate>Run.

Plotta bodediagrammet genom att vélja V(ut) som plotstorhet.

AC-analys kan ocksa anvandas till att plotta impedansen som funktion av frekvensen for en krets.
For att plotta inimpedansen i forstarkaren i exemplet: Klicka pa noden noden ”In”, hogerklicka pa namnet
i plotfonstret och ange algebraiskt uttryck for det som ska plottas. | vart fall:

V(in)/1(C1)

Om man klickar pa skalan vid vertikalaxeln och anger att vertikalaxeln skall ha linjar skala sa blir aven
enheten korrekt angiven i Ohm.
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11 Bestamning av stabilitetsmarginaler

Antag att man onskar bestdmma fasmarginalen for en forstarkarkoppling.

Standardmetoden for detta &r att bryta upp den slutna slingan pa ett lampligt stélle och bestamma
frekvensfunktionen for ett varv runt den slutna slingan och plotta motsvarande Bodediagram.

Nackdelarna med att bryta upp slingan &r att likstromsarbetspunkten i kretsen paverkas vilket kan ge en helt
felaktig smasignalmodell samt att man maste infora belastningsimpedanser for att inte andra
impedansnivaerna i den oppna kretsen i forhallande till den slutna kretsen.

I nedanstaende schema har en battre metod som brukar kallas Middlebrooks metod anvants vilket
eliminerar ovanstaende nackdelar.

Bryt upp kretsen i aterkopplingsslingan vid forstarkarens utgang.

Infoga en vaxelspanningskalla vid avbrottet enligt foregdende avsnitt om AC-analys.

Simulera med AC-analys. Se figur nedan.

Med plotfonstret aktivt: Plot Settings > Add trace eller tryck Ctrl+A

Under Expression(s) to add: -V(ut)/V(b)

Bodediagrammet for (-)slingforstarkningen (i reglerteknik kallad kretsoverféringen) plottas nu i
plotfénstret. | Bodediagrammet kan man nu avldsa fasmarginal och forstarkningsmarginal.
Normalt brukar man 6nska en fasmarginal stérre an 45°.

Vill man ha ett 6versvéngningsfritt stegsvar bor fasmarginalen vara storre an 75°.

FéjLTspice I¥ - Stability_test.asc By ] |
File Edit Hierarchy Yiew Simulate Tools Window Help

[P F QR B AR 2EA 08 LB 3 FDY O

14, Stabiliy_test asc |t: Stability_test.rawl

Stability_test.asc o ] 4

BN B AL R e i p ) B e 0 R e i o e e i L e e L e e
1Hz 10Hz 100Hz 1KHz 10KHz 100KHz 1MHz 10MHz
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12 Brussimulering

Antag att man vill bestimma brusnivan fran en forstarkarkoppling.
Rita upp nedanstaende krets:

mLTspice I¥ - Moise_test.asc - |EI|5|

File Edit Hierarchy Yiew Simulate Tools Window Help

P S F 0 QR B AR {2EAO8 LB+ 3 DY O

Noise_test.asc - 101 x|

R2

100k
+
-

+

= V1 o 15V

IN uT
- TLO71
V3 R1 > o
SINE(D 0.5V 1kHz) 10k V2 15V
-
.noise V{UT) ¥3 oct 10 10Hz 1MegHz

Valj Simulate > Edit Simulation Command
Hé&r kan man valja typ av simulering.

For brusanalys valj fliken Noise.

Fyll i enligt figur nedan. Bekrafta med OK

Edit Simulation Command x|

Tranzient I AL Analyziz I DC sweep Moise | DC Transfer I OC op pnt I

Perform a stochastic noise analyziz of the circuit linearized about itz DC operating
paint.

Output: IW

Input; I\-G—

Type of Sweep: m

Mumber of points per octave: |1D—
Start Frequency: W

Stop Frequency: W

Spntae: noize Y[<outx[.<ref>]) <sre> <oct, dec, liny <Mpoints: <StartFreqr <EndFreq:

noige YUT] Y3 oot 10 10Hz TMegHz

Cancel |

SPICE-direktivet .noise som talar om typen av simulering kan nu placeras i schemat.

Denna analys ar en smasignalanalys som forst gor en bestamning av likstromsarbetspunkten for kretsen.
Sedan beraknas en linjar smasignalmodell av kretsen runt arbetspunkten. Slutligen skapas en brusmodell
for kretsen mellan en undre startfrekvens f; och en 6vre stoppfrekvens f,.
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-

Kor en simulering Simulate>Run.

Plotta den spektrala brustatheten V[onoise] pa forstarkarens utgang genom att klicka pa utnoden UT.

V[onoise] &r angiven i enheten[ \Y }

VHz

ELTspice I¥ - Moise_test.asc -0 x|

File Edit Hierarchy Yiew Simulate Tools Window Help

PE R E0 R (B SRE BN AS(L LB EIFTDHO
1 Noi&e_te&t.asclh: Maise_test raw |
Moise_test.asc ;IEI il

v3
SINE(D 0.5V 1kHz)

=101

190nY{Hz =
180nY{Hz 4=
170nY{Hz 4=
160nY{Hz4=
150nY{Hz 4=
140nY{Hz 4=
130nY{Hz 4=
120nY{Hz5=
11 0nY{Hz 4=
100nY{Hz 4=
90nVjHz24=
80nVjHz25=

70nV{Hz2% '
10Hz

100KHz 1MHz
4

Effektivvardet av totala brusspanningen pa utgangen inom frekvensomradet f; < f < f, ges av:

f
Vews = .| [V 2[onoise]df
fy

Vrus erhélls i LTspice genom att Ctrl + Klicka pa V[onoise] i plotfonstret.
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Om man vill underséka hur mycket varje komponent bidrar till bruset pa utgangen sa ar det bara att klicka
pa komponenten.
I nedanstaende figur har man klickat pa R1 respektive R2.

ELTspice I¥ - Moise_test.raw — |EI|£|

File Wiew Plot Settings  Simulation  Tools  Window Help

| BT F0 R BY BT {dR2EHSE L LD L3 D0

‘l: Moise_test.asc t: Noise_test.rawl

R

R2

100K
+
=

+

> V1 o 15V

IN ut
~ TLO71
v R1 > -
SINE{D 0.5V 1kHz) 10k V2 15\.'

-

.noise V{UT) V¥3 oct 10 10Hz 1MegHz

=101.x]

200nV{Hz2 Y[onoise]

180nY{Hz 4=

160nV{Hz 4=
140nVjHz4~

120nV{Hz34=
100nY{Hz 4=
80n¥{Hz 4=
G0nY{Hz =
40n¥jHz4

20n¥{Hz 4=

On¥{Hz¥ Tt Tt Tt =TTy =TTy

10Hz 100Hz 1KHz 10KHz 100KHz 1MHz

Click ko manually enter Horizontal Axis Limits &

Den del av bruset som inte kommer fran de yttre komponenterna kommer fran operationsforstarkaren,
Vop, 0ch kan bestdmmas m h a operationsforstarkarens datablad eller enligt féljande:

Vop =V 2[onoise] —V,% —V,2 V2 — ...

dar V[onoise] &r den totala brustétheten pa utgangen och V, ar brustatheten pa utgangen som kommer fran
de yttre komponenterna (ovan V[rl] och V[r2] ).

Bruset fran operationsforstarkaren ar oftast hogre i verkligheten an vid simuleringen vilket beror pa att
alla bruskéllor oftast inte modelleras i macromodellen for operationsforstarkaren.
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13 Stegning av parametrar i krets

Vid alla typer av simulering kan man stega olika parametrar i kretsen, t ex resistans, kapacitans eller
spanning. Parametern kan stegas med Spice-direktivet:  .step

Exempel 1.
.Step param R 5k 9k 1k
Parametern R stegas frén 5 kQ till 9 kQ i steg om 1 k€.

Exempel 2.
.Sstep param C list 10u 22u 100u
Parametern C stegas efter listan och ges vérdena: 10 uF, 22uF och 100uF

Parametern som ska stegas anges i komponentmodellen inom klammerparenteser {} istéllet for
komponentvardet.
I exemplet nedan plottas frekvenssvaret for bandspérrfiltret da C antar vardena 10 puF, 22uF och 47 pF.

1ol x|

File Edit Hierarchw Wiew Simulate Tools Window  Help

| BEE T F0 QR B EABRY i2EH O 206
1, Draft2 = DraftEI ‘
=10l x|

uT

1K .step param C list 10u 22u 47u
V1 L1 100mH

AC1 .ac oct 10 10Hz 1kHz
c1 {c}

e

Viut] 100°
I"'E"'i'."E:-?:}:?:":':"F‘:E‘:?‘:‘:{“"?‘"‘%:::-i:":"I":. _T1k
GERREEEEIELES Ik
e 1
----- e 20
N
. . P ERREEEETEE ] ol |
e
. A A R A i
I |'"":'"'T"':"':":"%' = 'B[Iu
' r——r——r—r—t—r—r=100°
1KHz
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14 Simulering av temperaturvariationer

Vid alla typer av simulering kan man variera temperaturen. Om inget anges sker simuleringen vid
temperaturen 27 °C.

Temperaturen kan varieras med Spice-direktivet: .temp T, T, T3 T4 o0sv

Detta medfor att simuleringen kommer att goras vid temperaturerna Ty T, T3 T4 0sv
Alla temperaturer anges i °C .

Antag att vi i foregaende avsnitt vill se hur bruset paverkas av temperaturen vid temperaturerna
-40 °C, 25 °C samt 125 °C .

Edit>SPICE Directive eller T

och fyll i Spice-direktivet: .temp -40 25 125
Placera Spice-direktivet pa ditt schema och Simulera.

Nedan syns resultatet av simuleringen vid de tre temperaturerna.

F&jLTspice I¥ - Noise_test.asc oy ] 4

Eile Edit Hierarchy Yiew Simulate Tools Window Help
| PESEIT(F) QAR (B HRE IBEMAS LB+ YDV
| 'L: Moise_test.asc |t: Noise_tesl_[awl

Noise_test.asc -0l x|
=l

V3
SIHE(D 0.5V 1kHz)

noise V{UT) ¥3 oct 10 10Hz 1MegHz
Atemp -40 25 125

i

240nY¥{Hz
220nY{Hz
200nY{Hz =
180nY{Hz =
160nY{Hz =
140nY/Hz =
120nY{Hz =
100nY{Hz =

80nV/Hz=

KN

Bl]n‘-'.fHZ'g T T rrrerg T —r rrrerg T —r rrrerg T rrrrrerg T —rrrees

10Hz 100Hz 1KHz 10KHz 100KHz 1MHz
A
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15 La&gga till modeller i LTSpice installationskatalog

Det finns tusentals SPICE-modeller att ladda ner pa Internet.
Antag att du har laddat ner foljande diodmodell for dioden 1N4004

.model 1N4004 D (1S=76.9p RS=42.0m BV=400 IBV=5.00u CJO=39.8p M=0.333 N=1.45 TT=4.32u)

Oppna filen standard.dio:

File>Open vélj filen standard.dio och klistra in modellen bland de dvriga diodmodellerna. Spara.
Standard.dio finner du i katalogen C:\........ \LTC\LTspice\lib\cmp\.

Starta om LTSpice for att forandringen skall gélla.

Pa samma sétt klistrar du in nya bipolara transistormodeller i filen standard.bjt.

Att lagga till en mer komplicerad krets &r bara nagot svarare.
Antag att du laddat ner en modell med 5 benanslutningar fér OP:n TLO71.
Modellen bérjar med raden:

SUBCKT TLOTL e

Oppna filen opamp.sub:

File>Open

opamp.sub finner du i katalogen C:\........ \LTC\L Tspice\lib\sub\.

Radera innehallet och klistra in din modell.

File>Save As: Vélj Save as type: All files. Spara under filnamnet: TLO71.sub.

For att koppla en symbol till din modell gor enligt féljande:

Oppna filen LT318A.asy:

File>Open valj filen LT318A.asy

LT318A.asy finner du i katalogen C:\........ \LTC\L Tspice\lib\sym\Opamps\.

Nu kan symbolen redigeras. Men om den ar till belatenhet s& andrar vi bara symbolens attribut:
Edit>Attributes>Edit Attributes
Andra enligt figur nedan:

Il 5ymbol Attribute Editor |
Symbol Type: IEeII 'I

attribute | walle |
Prefis bt

SpiceModel TLOT.sub

Yalue TLaA

Y alue? TLOA

Spiceline

Spiceline2

D escription JFET Operational Amplifier

ModelFile

Cancel |

Bekréfta med OK
File>Save As: Spara under filnamnet: TLO71.asy
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16 Lagga till modeller i LTSpice om man INTE kan/vill skriva i LTSpice
installationskatalog

Det finns tusentals SPICE-modeller att ladda ner pa Internet.
Antag att du har laddat ner féljande diodmodell for dioden 1N4004

.model 1N4004 D (1S=76.9p RS=42.0m BV=400 IBV=5.00u CJO=39.8p M=0.333 N=1.45 TT=4.32u)

Skapa m h a en texteditor en biblioteksfil med namnet xxxx.lib och spara den i din projektkatalog.
(xxxx godtyckligt namn)

Klistra in din diodmodell i filen xxxx.lib.

For att kunna anvanda modellerna i biblioteket xxxx.lib skapa ett Spicedirektiv i LTSpice enligt foljande:

Edit>SPICE Directive eller T

Skrivin:  .INCLUDE xxxx.lib och placera Spicedirektivet pa din schemaritning.

For att anvanda diodmodellen placera en diod pa schemaritning, hogerklicka pa vérdet D och skriv in
namnet pa din modell d v s 1N4004.

Pa samma sétt klistrar du in nya transistormodeller i filen xxxx.lib och anvander dem genom att
hogerklicka pa vardena NPN, PNP etc och valjer din transistormodell.

Att lagga till en mer komplicerad krets gors pa samma satt.

Antag att du laddat ner en modell med 5 benanslutningar for OP:n TLO71.
Modellen bérjar med raden:

SUBCKT TLO7TL oo

Klistra in din modell i filen xxxx.lib.

For att anvanda modellen placera opamp2 pa din schemaritning, hogerklicka pa véardet opamp2 och skriv
in namnet pa din modell d v s TLO71.

opamp2 hittar du under T [opamps].

Lagoa till hela tredjeparts bibliotek med modeller och symboler i LTSpice

Om du laddar ner ett helt bibliotek komplett med symboler sparar du biblioteksfil (xxxx.lib) och alla
symbolfiler (.asy) i din projektkatalog.

For att kunna anvanda modellerna i biblioteket xxxx.lib skapa ett Spicedirektiv i LTSpice enligt foljande:

Edit>SPICE Directive eller T

Skrivin:  .INCLUDE xxxx.lib och placera Spicedirektivet pa din schemaritning.

Nér du vill placera komponent valj T samt vélj som Top Directory din projektkatalog vilket ger dig
tillgang till alla symbolerna (med tillhérande modell) som finns i din projektkatalog



